Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

no menu items selectable - Xmind 8 & Mac OS High Sierra GM

Mario Sep 21, 2017 11:39PM HKT

Hey there,

I just tested the new version xmind-8-update4-macosx on an Mac OS High Sierra GM System.

The application starts, but all menu items are grey out, so nothing is selectable in the menu.

Do you have a work-around, or a bugfix?

Best regards,
Mario

Up 8 rated Down
Ralf Sep 24, 2017 05:27AM HKT
Same for me, and in 2 days High Sierra is no Beta anymore ;-(
Up 6 rated Down
Marcel Sep 26, 2017 02:17AM HKT
same here .... arg
ANOYING!!!!

pls fix asap!
Up 1 rated Down
samfisher Sep 26, 2017 09:00PM HKT
yes, same problem with me. some permission issue?
Up 1 rated Down
Christian Sep 26, 2017 10:01PM HKT
I have the same problem and I hope that there will be a solution.
Version: XMind 8 Update 4 (R3.7.4.201709040350)
Please fix it!
Up 1 rated Down
ALMALEH Sep 27, 2017 12:13AM HKT
I have the same problem !! Urgent
Up 2 rated Down
Cary Sep 27, 2017 11:44AM HKT
Me too.....I have the same problem, hope fix it up ASAP....
Up 1 rated Down
Cary Sep 27, 2017 12:17PM HKT
I think it maybe Eclipse problem, because Xmind develops base on Eclipse....

https://bugs.eclipse.org/bugs/show_bug.cgi?id=520176
Up 6 rated Down
Christopher Sep 27, 2017 02:36PM HKT
This has to do with Eclipse. I found the answer at

https://www.eclipse.org/org/press-release/20170925criticalbug.php

For Xmind--> Right click on X-mind, show package. Under the folder "Contents" there is a file called "info.plist" Open with TextEditor. Search for "CFBundleLocalizations" (something like the one below but a bit shorter) Remove all of it and save the file.

<key>CFBundleLocalizations</key>
<array>
<string>ar</string>
<string>cs</string>
<string>da</string>
<string>el</string>
<string>en</string>
<string>es</string>
<string>de</string>
<string>fi</string>
<string>fr</string>
<string>hu</string>
<string>it</string>
<string>iw</string>
<string>ja</string>
<string>ko</string>
<string>nl</string>
<string>no</string>
<string>pl</string>
<string>pt_BR</string>
<string>pt</string>
<string>ru</string>
<string>sv</string>
<string>tr</string>
<string>zh_HK</string>
<string>zh_TW</string>
<string>zh</string>
</array>

Open the "Eclipse" folder. There is a file called "Xmind.ini" In that file add "-Duser.language=en" at the bottom. Save and close. Start Xmind and the menus should be there.
Up 1 rated Down
Dominique-Alain Jan Sep 27, 2017 07:59PM HKT
Same problem here.
Up 0 rated Down
linjh Sep 28, 2017 01:50PM HKT
Thank Christopher. The interface is English.
But if I prefer the zh-TW interface. How can I do that?
Up 2 rated Down
Christopher Sep 28, 2017 04:51PM HKT
Well, that is the bug

"When Eclipse is launched on macOS 10.13 and user's primary language is not set to English, all the menu items in the main menubar are disabled. However, Context menus are not disabled."

So, if you force eclipse/Xmind to use english it will work. Otherwise not. To make another language work Eclipse needs to be fixed/upgraded.
Up 0 rated Down
linjh Sep 29, 2017 11:04AM HKT
Well, thank Christopher again. Hope xmind would settle this bug in the near future. (for maybe only some Mac high sierra users whose primary language is not English).
Up 0 rated Down
Martin Sep 30, 2017 08:32PM HKT
Maybe it's just sufficient to edit the eclipse-ini file in the way Christopher has described it. I did try to set language to de (german)but it did not work. So for me just adding the line "-Duser.language=en" in XMind.ini without any changes to Info.plist did it. For me it is not a problem to use English as default until it has been fixed.
Up 0 rated Down
Michel Oct 02, 2017 11:37PM HKT
Same issue for me :(
Incredible that Xmind team doesn't test with High Sierra. This is totally unprofessional and not the first time we get some problem like this...I guess we will look for a more professional tool in the future...Since Mario message the 21st of September no comments from Xmind...very disappointed and unprofessional :(
Up 0 rated Down
Gilles Oct 03, 2017 05:05PM HKT
Thank you very much Christopher for the solution !
Up 0 rated Down
Mauricio Moreira Guzmán Oct 06, 2017 11:31AM HKT
I Download the latest version of XMind (8 Update 5 Pro), and thissolve the problem.

https://www.xmind.net/download/
Up 0 rated Down
Helder Nov 03, 2017 06:04AM HKT
Problem resolved with the tips of the Christopher...Thanks.

This question has received the maximum number of answers.

support2@xmind.org
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete