Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

XMind starts but then is aborted just before starting to run

Antonio Sep 22, 2017 05:31PM HKT

Hi,
I just installed XMind8 in Ubuntu 14.04 but can't make it to run. Is is aborted just a few seconds after the XMind8 image is projected on the screen.

Below is some of the log entries:
Can you please help?

!SESSION 2017-09-22 11:21:34.142 -----------------------------------------------
eclipse.buildId=R3.7.4.201709040350
java.version=9
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=es_ES
Framework arguments: -eclipse.keyring @user.home/.xmind/secure_storage_linux
Command-line arguments: -os linux -ws gtk -arch x86_64 -data @user.home/workspace -eclipse.keyring @user.home/.xmind/secure_storage_linux

!ENTRY org.xmind.cathy 1 0 2017-09-22 11:21:49.453
!MESSAGE Skip unrecognized command line argument: '-eclipse.keyring'

!ENTRY org.xmind.cathy 1 0 2017-09-22 11:21:49.454
!MESSAGE Skip unrecognized command line argument: '@user.home/.xmind/secure_storage_linux'

!ENTRY org.eclipse.osgi.compatibility.state.nl_ko 2 0 2017-09-22 11:21:49.803
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ko [846]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_sl 2 0 2017-09-22 11:21:49.803
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_sl [849]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state

[snip]


!ENTRY org.eclipse.osgi 4 0 2017-09-22 11:21:49.807
!MESSAGE Error de aplicación
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:386)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:294)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:490)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:504)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:203)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:626)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:604)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.xmind.cathy.internal.CathyApplication.start(CathyApplication.java:145)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:564)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:151)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:375)
... 23 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.0.v20160319-0612
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:398)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:361)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:353)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
... 25 more

Up -1 rated Down
Leon Sep 24, 2017 08:32PM HKT
Same problem here ... would be great to know a solution :)
Up -1 rated Down
dario Oct 05, 2017 01:05PM HKT
I solved this problem just naming (for security reasons) the .xmind directory in your home directory, when you start the xmind program it creates the files!
Up -1 rated Down
Jerome Oct 18, 2017 08:33AM HKT
Same issue there. I created the directory but still the same error. On Linux Mint 18.2 based on Ubuntu 16.04.
Up 19 rated Down
Gijsbert Wiesenekker May 10, 2018 08:04PM HKT
Append the line

--add-modules=java.se.ee

to XMind.ini resolves this error, also on Ubuntu 18.04.

Regards,
Gijsbert
Up 11 rated Down
Juba Chabour May 12, 2018 07:18AM HKT
Hello,

Same issue i'm working on Ubuntu 18.04 with Xmind and that's how i resolve it :

Write on your terminal : sudo gedit "/opt/xmind/XMind_amd64/XMind.ini"

And add this

-vmargs
--add-modules=java.se.ee
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m

So that's what it will be look's like :

-configuration
@user.home/.configuration
-data
@user.home/workspace
-startup
/opt/xmind/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
--launcher.library
/opt/xmind/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.400.v20160518-1444
--launcher.defaultAction
openFile
--launcher.GTK_version
2
-eclipse.keyring
@user.home/.xmind/secure_storage_linux
-vmargs
--add-modules=java.se.ee
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-Dfile.encoding=UTF-8

Regards
Up 0 rated Down
Tarasvadim Jul 10, 2018 09:45PM HKT
Juba Chabour, It works, thanks.
Up 0 rated Down
Stanley Stephen Jul 19, 2018 10:31PM HKT
THANK YOU!!!
This works. I would not have figured this out on my own.
Up 0 rated Down
Souvik Jana Sep 01, 2018 11:55PM HKT
Thanks all. This works.
Up 0 rated Down
Pablo Feb 10, 2019 05:54AM HKT
In Mint 19.1 I had the same problem. After many hours, searches, tries and frustrations, the simple answer was the one by Gijsbert. THank you!!!
Up 0 rated Down
trutr Mar 09, 2019 04:28PM HKT
Make sure you add --add-modules=java.se.ee in Gijsbert's post at the very end of the file. That did the trick ! THANK YOU Gijsbert!!!!!

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support2@xmind.org
http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete