Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Xmind 8 is performing very slowly after updating to Mac OS High Sierra

Werner Oct 10, 2017 09:30PM HKT

After I updated macOS to High Sierra Xmind 8 (Update 5) is performing very slowly. Is Xmind optimized to High Sierra?

MacBook Air 1,3 GHz, i5, 4GB RAM, MacOS HighSierra



Up 2 rated Down
Michael Oct 11, 2017 06:36PM HKT
I am experiencing the same issue. I have the newest MacBook Pro and it's just too laggy to use.
Up 4 rated Down
Stephen Oct 15, 2017 06:26PM HKT
I am experiencing the same issue. I am a new user of Xmind and I am trying to use it on two iMacs both running High Sierra. One is a year old and the other is brand new and both have the same spec - 3GHz processor and 8GB memory and 2GB video memory. The software is completely unusable and I am spending more time correcting typing mistakes caused by the lag than I am doing what I wanted to do in the first place. I am very much regretting having spent money on the Pro version.
Up 2 rated Down
Max Oct 19, 2017 07:26PM HKT

I agree, since High Sierra update, even small maps with 20 items are lagging just to scroll or type text?

I use it on a 2 month brand new MacBook Pro with 16Go of RAM and a 2,9 GHz Intel Core i7 so ... nothing should be a problem.

I paid for the pro version too and I can't use it now !

@Support : Any update about a fix ?

Up 1 rated Down
Til Oct 20, 2017 07:29PM HKT
Hi, I got the same issue right now. I updated to 8 Update 5 (R3.7.5.201709290120) but unfortunately it's still very slow and nearly not possible to work with. I hope for a quick update, because I think, it's one of the best mind mapping tools there are.

Up 0 rated Down
Josep Maria Oct 25, 2017 01:03PM HKT
I am experiencing the same issue. I have the newest IMac 5k and it's just too laggy to use.
Up 1 rated Down
Fabio Anziani Oct 30, 2017 12:41AM HKT
I'm experiencing the same performance issues with Xmind 8 Pro Update 5 on macOS High Sierra installed on an brand new iMac 5k . It's really slow and after a few minutes the lag on typing makes him unusable.

I understand that OS upgrades sometimes come with compatibility issues but please, I think we deserve at least an answer.

Letting your customers in the dark is not exactly a good move.
Up 2 rated Down
Chris Nov 07, 2017 10:52AM HKT
I got the same issue too.

I use the newest MacBook Pro and the High Sierra upgrade makes Xmind barely usable for me. Some feedback would be nice.

Up 0 rated Down
Neo Nov 18, 2017 02:55AM HKT
I got the same issue too.

I use the MacBook Pro 2016 and the High Sierra upgrade.
Up 0 rated Down
Jason Nov 20, 2017 11:12AM HKT
I got the same issue too.

I use the MacBook Pro (Retina, 13-inch, Early 2015) and the High Sierra upgrade.
Up 0 rated Down
Edwig Nov 20, 2017 10:28PM HKT
Same problem

Answer from XMind please ?!?
Up 0 rated Down
Alder Stone Nov 23, 2017 09:33AM HKT
My free version of XMind 8 is not merely slow with High Sierra (2015 MacBook Pro; existing maps won't load at all. Very concerned because my maps are one of the cores of my professional work. I've tested all other tools, including video production software which works fine. I've resolved an issue of my camera not transferring images. But this could be a deal breaker. Glad I backed up before upgrading to HS, but I hope this can be repaired quickly.
Up 1 rated Down
Alder Stone Nov 23, 2017 09:42AM HKT
Has anyone tried this fix suggested for Sierra users?

Scroll to the (current) post 4 by Sergey.
Up 1 rated Down
Ben Nathanson Nov 23, 2017 04:50PM HKT
Yup, same issue here. Did anyone get a response from XMind on this?

Is it a bug or does XMind 8 not work with 10.13.1?

If so does this mean they are going to make us all pay for an upgrade?



Up 0 rated Down
Alder Stone Nov 25, 2017 12:10AM HKT
Here's an update to my posts above. I was preparing to contact XMind Support via email ( from their contacts page. One factor they want to know is what version of XMind are you using.

So, I opened XMind (again, I have the trial version), and got the version number -- XMind 8 Update 2, plus some long number. But I decided then to try to create a new map; I haven't done that since upgrading to High Sierra.

I created a simple new map, then saved it, and reopened it. Functioned without a glitch.

So then, on a lark, I decided to try again to open one of my existing maps, created before the HS upgrade.

IT OPENED!!!! Fully functional.

Then I opened my other one, my main one, upon which my professional work for the next few years will manifest, for which I'm creating a new web site.

IT OPENED!!!!!! Again, fully functional, and I can navigate it at normal speed. (It's a HUGE map, so ...)

Color me happy now.

My suggestion: for those of you using High Sierra but experiencing troubles, try creating a new map with just a couple of topics and subtopics, saving, reopen, then try your older maps/files.

I have zero idea if (or why) it will help you, but in the world of computational systems like interacting software, emergent phenomena happen that aren't really explainable in logical terms. Worth a try.

Hope this helps.

Up 0 rated Down
Bruno Dec 30, 2017 12:55AM HKT
I have followed Mr. Stone's tip with a slight adaptation, which worked for XMind8PRO for Windows.

I have pasted my map, which I had created before upgrading and which I was using with some difficulties on XMind8PRO, in a new empty map. Performance has improved and the outlook of the map now is the one of XMind8Pro.

Up 1 rated Down
julian brearley Feb 01, 2018 12:21AM HKT
Takes ages to load - minutes! That's just loading the programme without opening a file (which also takes an age)

Unusable in it's current form
Up 0 rated Down
Christian D Aug 09, 2018 11:36PM HKT

Can we please have any News and statemend from you Xmind? 7.5 is as slow as well. When in "Notes" or eding text etc and then clicks the mind map area seconds goes by without anything happening. If you ie. scrolls during those seconds the program will respond to users inputs after those seconds, when app it seems to respond again...

VERY Annoying! :(
That makes it hard to work, thinking about not paying for PRO version and look into optional mind map apps.

Otherwise Xmind is GREAT! :) So sad and frustrating with this bug?...
Up 0 rated Down
Christian Djurber Aug 09, 2018 11:52PM HKT
Support please?

For me (now downgraded to 7.5) and troubleshooting this, puting my work hours into troubleshhoting os no funny money...

But in my case on Windows 10 latest updates of cource, both on Laptop and PC.
The issue described above seems to be in a certain 99,9% for me when opening/ having the "Notes" open up in a TAB, F4 key and pin along in the other tabs area. Seems to be the problem for this.

If just using the "Notes" pop-up instead it doesnt affect the performance at all... Strange! And shouldnt be a strange or hard fix you could argue and assume?

Whats the status of the ongoing? Xmind continuous development?

Up 0 rated Down
ParamindX Oct 26, 2018 12:44AM HKT
same here. No support?
Up 0 rated Down
Dennis K. Nov 02, 2018 05:24AM HKT
This solution can help:

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found