Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

iOS App not opening Maps

Chris Rouse Dec 13, 2017 09:27PM HKT

I downloaded the iOS XMind App and tried to open maps that I have saved in my iCloud drive. I see the files but the new app will not open them. I then created a new map using the iOS XMind App which worked fine but after closing it, I am not able to re-open it. Please advise resolution.


Up 4 rated Down
Scott Dec 15, 2017 05:53AM HKT
I have the same problem. Very frustrating.
Up 1 rated Down
John Dec 15, 2017 04:58PM HKT
Same issue. Continues with v1.02.
Up 1 rated Down
Alison Charles Dec 16, 2017 02:21AM HKT
I have the same issue. I was excited to try the new app but it doesn’t open any files from anywhere including those created with the Zen beta - even local files won’t open they are all greyed out. You can create a file from a template but not edit it.
Up 1 rated Down
Greg Towne Dec 16, 2017 09:18AM HKT
This is very frustrating guys.

Updated my version on my Mac and downloaded new version for my iPad Pro to ensure it was not a versioning thing.

I can see the xmind file in iCloud (created on my Mac) but can not open the thing on my iPad.
Up 1 rated Down
Chris Rouse Dec 16, 2017 11:38AM HKT
After messing with this the past two days, I realized that all of my XMind files were still associated with an app named iThoughts that I have also used for maps. Since iThoughts does not have an updated version, I removed that app from my iPad and the new XMind App started working as expected.

If you have other map apps on your iOS devices, you may want to remove those from the device and see if that will correct the problem.
Up 0 rated Down
John Dec 16, 2017 04:22PM HKT
Confirming Chris' suggestion. Removing other mapping apps allows Xmind to work. In reality though Xmind should work independently of an other mapping app.
Up 1 rated Down
BobF Dec 16, 2017 05:47PM HKT
Yes, same as reported by others ... used to have iThoughts on iPad (but no longer) ... deleted all other mind mapping apps (been trying several) and now XMind will open it’s files.

Shouldn’t need to have done that.
Up -1 rated Down
Matt Wood Dec 17, 2017 07:57AM HKT
I had the same issue but it's now fixed thanks to BobF. Thank you! I had iThoughtsHD (which no longer works). After I deleted it i could open XMind files again. Awesome. Suspect it's some issue with the iPad file associations rather than XMind itself.
Up 0 rated Down
Josef Sachs Dec 17, 2017 09:06PM HKT
I have the same problem. I removed iThoughts, but that didn't help.
Up 1 rated Down
Alison Charles Dec 19, 2017 12:19AM HKT
We should not have to remove other apps to make XMind work. I use several mind-mapping apps and need to continue to do so. Not impressed with this work around.
Up 0 rated Down
Morgain Dec 19, 2017 07:38PM HKT
HI everybody
Same problem. I don't have Thought so it can't come from it
Up 0 rated Down
Juley Dec 28, 2017 11:17PM HKT
Same problem - please resolve. App is useless! I don’t want to delete all my mindmapping apps from my ipad...
Up 0 rated Down
Frank Gerritsen Dec 29, 2017 10:07PM HKT
I had the same probleem yesterday. After installing the latest beta version yesterday the probleem was solved. However I installeert just the latest version 1.05 and now the problem is back again. Please solve this problem at a short notice because your app is worthloss in this way.
Up -1 rated Down
John Dec 30, 2017 07:27AM HKT
Frustrated and said so with a product rewiew at the Apple Store. Following Bob’s suggestion, I also removed other mindmap apps - iThoughts and Xmind for cloud. And, rebooted afterwards. Still is a zero. I try to open a new map from available templates and nothing happens. No new appears and I can’t open any native xmind from MAC or Windows versions of Xmas. Maybe, its time to go back to iTHoughts, which works on many different platforms.
Up 0 rated Down
Alison Charles Jan 02, 2018 06:41PM HKT
I have reported this to their support and even sent additional screenshots etc. I got the distinct impression that they were unaware of this thread as they asked me for a link to it! No response since and another release without this being fixed. How can we help to test this if we can't even open the files!
Up 0 rated Down
Alison Charles Jan 02, 2018 06:56PM HKT
John, did your review get published on the App Store? I can't see it and I have tried to add a review twice and it is not appearing even though the send is successful.
Up 0 rated Down
Dan Teodorescu Jan 04, 2018 06:47PM HKT
In my case, the files are associated with... Yahoo Mail.
I deleted Yahoo Mail... the files were associated to... Slack.

So just deleting the apps won't work (unless I delete all of them? :) )
Up 0 rated Down
Kurt Jan 07, 2018 04:46PM HKT
I just tried the app yesterday.
It wasn't possible to create any MindMap.
App deleted instantly.

Sorry to say that.
Up 0 rated Down
Alison Charles Jan 09, 2018 12:33AM HKT
There was an update to the app today. I installed it and my hopes were raised for about 5 seconds. Unbelievable that this problem STILL EXISTS!! Do any developers in XMind actually read this Support Centre???
Up 0 rated Down
Alison Charles Jan 12, 2018 05:51PM HKT
It's fixed!!
I downloaded the latest version this morning and this problem seems to have been fixed. If this bug has put you off trying the app, I can tell you that it is well worth going back and having a look - it's really good. I have opened some really large maps on my iPad and it's coped fine so far. The usual beautiful X-Mind look and feel is there too.
Thank you developers, you made my day!
Up 0 rated Down
Sopon Jan 14, 2018 03:50PM HKT
The same here but with the latest update (12 Jan) now I can create the new map. Still cannot open the existing maps even the one created by XMind stored in my iPad or my clouds. My existing maps are associated with OneNote... this can’t be!
Up 0 rated Down
Dave Jan 28, 2018 08:14AM HKT
I've had the same issue but think I found a work around.

Issue: Creating a map on my Mac, saving it to iCloud (or Google Drive) and not being able to open it on my iPad.

Workaround: I switched to XMind Zen (opposed to XMind 8). Created a brand new file in either iOS or in Zen. Saved it to iCloud and am able to open on either device.

The issue seems to be with older mind maps created in the original XMind app; including those created on Windows. Opening an existing file in Zen didn't work either.

Hope this helps. And I hope they fix it.
Up 0 rated Down
Manuel Jun 06, 2018 02:25PM HKT
Strange as it seems, I emailed the map from XMind 8 (Windows) to my iPad and used OneDrive for storage (Method 3), not Method 1 in the link and it worked. I hope it helps.
Up 0 rated Down
Jarred Aug 10, 2018 10:22AM HKT
Same problem. I am using google drive on iPad, cannot open the file, even cannot create a file. It will pop up an error prompt when trying to create a file on google drive.
Up 0 rated Down
Juha Metsäkallas Sep 25, 2018 08:17PM HKT
I have a file, that I've originally created on Xmind 7.x. Lately I've used Xmind 8 update 7 (the newest) to modify it. I can open it on my computer using Xmind ZEN, albeit some colours are off. The theme of the map is a slight modification of one the built-in themes.

On Ipad opening from Icloud does work. I can send the map from Icloud to Xmind, Xmind becomes active but then nothing else happens, the map never shows up.

OneDrive on Ipad doesn't offer Xmind as a target for opening.

Via Evernote I get the map into ZEN, but it always arrives damaged.

The Ipad has never had another mind map application.
Up 0 rated Down
Christophe Oct 09, 2018 10:13PM HKT
Same here. Extensions names files and associations problems prevent Xmind to open its own files on the iPhone with Google Drive.
Up 0 rated Down
Christophe Oct 09, 2018 10:40PM HKT
All those problems could be related to the new Apple "Files" app which came with iOS 11 in Sept 2017?
Up 0 rated Down
Alex Soler Nov 01, 2018 07:02PM HKT
Recently acquired a iPhone XR. I've downloaded XMind mobile. Using Dropbox as cloud. I can sometimes open the maps created in XMind Zen PC, then close them, to never be able to open them again.

Very frustrating. If the app is not ready they should not offer it, or at lease give feedback about the reported bugs

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found